Hyundai Palisade Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello everyone. I just took delivery of a new 2021 Palisade Calligraphy. The first drives went great and then later in the day, the instrument cluster screen went blank. There is nothing there anymore. The main console where the gear buttons are is now flickering as well. The car drives perfectly and there are no issues with the infotainment system, All other electrical systems in the car are working as expected. I have tried searching the forums and internet for something similar and have come up empty. The service center seems confused and the fuses are good. Any ideas I can try? Oh and yes, there is a smell, not strong, but its there.

Thanks.
 

·
Registered
Joined
·
27 Posts
The dealer let you take your car back with the instrument cluster going blank because they didn’t find a blown fuse? No speed, warning, or gear read outs.
 

·
Registered
2020 Palisade SEL Lagoon Silver
Joined
·
446 Posts
If the cluster isn't working, it should be sitting at the dealership and I would be driving a loaner until it is fixed. And welcome to the stinky Nappa leather club. Many others have it, have complained about it and Hyundai has no solution for it yet. Some people have a very strong smell that makes them ill, some it's not so bad. Some will say it's only one color, but it's been reported by people with other colors as well. I'm just thankful I hate leather seating and would never own a car with it.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Good afternoon, and an update. To answer the question, yes they let me take it home and I brought it back this morning. So far, no other updates.. I was holding out hope that someone in these parts had seen something similar.
 
1 - 4 of 4 Posts
Top