Hyundai Palisade Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 · (Edited)
I'm having a problem putting the A-Pillar back in after removing it so I can install the dashcam. It would go in but very loose and even touching with little force you can feel it loosen.
I'm not sure what I am supposed to do to put it back in smug, I try to use force to push it in but nothing really change. I've removed again to see if the wire is blocking the way but don't see anything. Does anyone have any tips on how to put it back in?

Here is a video showing how loose it is.

 

·
Registered
2022 Calligraphy
Joined
·
33 Posts
I had the same trouble. What worked for me was inserting the side closest to the front windshield first good and snug then press the other side in. It helped by looking from the outside thru the front windshield.
 

·
Registered
Joined
·
398 Posts
If you open the door and pull out the door seal rubber a little, it might help. I pulled out the rubber, it slides off easily, and pushed the camera power cable under that cover. I has to be able to pop open easily if that air bag deploys.
 

·
Registered
Joined
·
18 Posts
Are you sure the upper fastener is still in good shape? If you just pulled the cover off, you may have damaged the 2 little ears that hold it into the frame. If so, it won't hold just as seen in you video. When I removed my cover I used a tool to disengage the little ears, but one of them still didn't quite look right so I replaced the fastener. You can get them from the dealer or on line for about $7.
 
1 - 5 of 5 Posts
Top